We're currently having issues with our Datacenter infrastructure
Incident Report for Mercur Solutions AB
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 15:33 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2020 - 12:53 CET
Identified
We are currently having an issue with our Datacenter provider.


We are actively working on solving the issues and will publish updates as they become available.
For further questions, please contact us at support@mercur.se.
Posted Jan 17, 2020 - 12:02 CET