Issue with accessing Mercur SaaS
Incident Report for Mercur Solutions AB
Resolved
We had some issues with our network around 11:00 which caused a short disturbance which is fixed and we are monitoring the solution
Posted Mar 12, 2019 - 11:00 CET