Outage in Sweden

Incident Report for Mercur Solutions AB

Resolved

All systems operational.
Posted Sep 08, 2025 - 09:33 CEST

Monitoring

Issue has been identified and mitigation initiated, we are monitoring the results. Please contact customer support if you are still experiencing problems.
Posted Sep 08, 2025 - 08:50 CEST

Investigating

We are experiencing an outage with the Mercur software and are currently investigating the issue.
Posted Sep 08, 2025 - 08:36 CEST
This incident affected: Sweden (Web Services).