Degraded performance
Incident Report for Mercur Solutions AB
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 13:37 CEST
Identified
Our performance is currently degraded due to outages within our hosting provider.
Posted Sep 13, 2021 - 13:01 CEST
This incident affected: Mercur Cloud Service, Infrastructure Service, and Integration Service.